1sting

Time Limit: 5000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5235????Accepted Submission(s): 1987

Problem Description

You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’,or leave the ‘1’ there. Surly,you may get many different results. For example,given 1111,you can get 1111,121,112,211,22. Now,your work is to find the total number of result you can get.

?

Input

The first line is a number n refers to the number of test cases. Then n lines follows,each line has a string made up of ‘1’ . The maximum length of the sequence is 200.

?

Output

The output contain n lines,each line output the number of result you can get .

?

Sample Input

  
  
   
   3 1 11 22222
  
  

?

Sample Output

  
  
   
   1 2 8
  
  

?

Author

z.jt

?

Source

2008杭电集训队选拔赛——热身赛

?

Recommend

题意:

所给由1组成的串,每相邻的两个1可以变成一个2,求共有多少种不同的变法;

推出几组,你就可以发现是斐波拉切数列,即F[i]=F[i-1]+F[i-2];这里的i就是所给串的长度;

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
typedef long long ll;
using namespace std;
#define INF 0x3f3f3f3f

#define N 250
char str[N];
int a[N][1100];   ///F[200]应该不会超过1100为的

void init()
{
    int i,j;
    memset(a,sizeof(a));
    a[1][0]=1;
    a[2][0]=2;
    for(i=3;i<=201;i++)
    {
        for(j=0;j<1100;j++)
        {
            a[i][j] += a[i-1][j]+a[i-2][j];
            if(a[i][j]>=10)
            {
                a[i][j+1] =a[i][j+1]+a[i][j]/10;    ///刚开始把这里两个等式位置颠倒了,一直不进位,搞得很无奈啊。。。傻!!!
                a[i][j]=a[i][j]%10;
            }
        }
    }
}

int main()
{
    int n,i,len,index;
    init();
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",str);
        len=strlen(str);
        for(i=1099;i>=0;i--)
        {
            if(a[len][i]!=0)
            {
                index=i;
                break;
            }
        }
        for(i=index;i>=0;i--)
        {
            printf("%d",a[len][i]);
        }
        printf("\n");
    }
    return 0;
}

dawei

【声明】:北京站长网内容转载自互联网,其相关言论仅代表作者个人观点绝非权威,不代表本站立场。如您发现内容存在版权问题,请提交相关链接至邮箱:bqsm@foxmail.com,我们将及时予以处理。